Software and patch management in HP-UX is done using HP Software Distributor called SD-UX. The software in SD-UX is organized in a hierarchy of components or objects. These components are filesets, subproducts, products and bundles. The place where these components are stored is called a software depot.
Few Common Terms in SD-UX :
Filesets: It is a collection of files and some control scripts. It is the basic entity in the SD-UX hierarchy. One file set can belong to only on product. But it can be included in a number of sub-products and bundles.
Here is an example: Keyshell.KEYS-END-A-MAN B.11.30
where
1st field is the fileset name
2nd field is the fileset version
Sub-products: If a file set contains several filesets, it is better to combine logically related filesets in to subproducts.
Here is an example:
X11.MessagesByLang X11 Localized Messages
This sub-product contains the filesets for X11 messages in several languages.
Product:
It is nothing but a set of filesets. In another words, it is a superset of filesets / subproducts.
Here is an example ,
X11 B.11.30 HP-UX X Windows Software
where
X11 is the product name
B.11.30 is the product version
third field is the product description
Bundles: Bundles are usually packaged by HP-UX for the distribution of software. The bundle may contain filesets that may belong to different products.
Here is an example,
OnlineDiag B.11.20.06 HP-UX 11.0 Support Tools Bundle
Patch Commands
swconfig - configure software / patches
swlist - display software / patch information
swinstall - installs software / patches
swremove - removes software / patches
Patch Logs / Listing
/var/adm/sw/swagent.log --> contains entries from swagent daemon
/var/adm/sw/swinstall.log --> entries/errors from swinstall
Gather Patch Install/State data
swlist -l fileset -a state PH* > /tmp/swlist.txt
swlist product PH* > /tmp/swlist.txt ( $ swlist -l product 'PH??_*' )
Other patch Commands
check_patches --> Checks for common problems and issues ie. Patch attributes, missing patch filesets, etc.
/usr/contrib/bin/show_patches ---> displays only active patches on system
How to tell what patches are loaded using the swlist command (10.x)?
Patches are named PHxx_nnnn, where xx can be KL, NE, CO, or SS.
nnnn refers to the patch number, which is always unique no matter what PHxx category is specified.
If a patch has been loaded on a 10.x system, the patch should be listed in the output of swlist . All patches named PHKL*, and some patches named PHNE*, are kernel patches.
A patch name consists of the characters "PH" (Patch HP-UX), followed by a two-character type-identifier, followed by an underscore, followed by a four or five-digit number.
The currently defined patch types are:
CO - COmmands & libraries
KL - KerneL
NE - NEtworking
SS - SubSystems
Kernel patches always require a system reboot, so that the newly updated kernel can be loaded. Many Networking patches (PHNE*) also make modifications to the kernel, and hence require a reboot.
Note that the numerical portion of any given patch name is unique, among ALL patches. So there would never be a patch named "PHCO_23507", in addition to a patch named "PHKL_23507." This lends itself nicely to grepping for a particular patch (ie - to see if "PHKL_23507" is installed, one could use "swlist -l product | grep 23507" .
QPK = Quality Pack - which is a bundle of patches that HP provides twice yearly for each version of HP-UX.
HP-UX 11i v2
# swlist -l bundle BUNDLE11i HWEnable11i FEATURE11i QPKBASE QPKAPPS
HP-UX 11i v3
# swlist -l bundle BUNDLE11i HWEnable11i FEATURE11i QPKBASE
Contrast the installed patches against the latest available on www.itrc.hp.com
Examples :
To list the installed bundles :
# swlist -l bundle
To list the installed products :
# swlist -l product
To list the installed subproducts :
# swlist -l subproduct
To list the installed filesets alone :
# swlist -l fileset
# swlist -l fileset openssl
To list all the files belonging to the product X11 or fileset openssl :
# swlist -l file X11
# swlist -l file openssl
To open swlist in GUI mode :
# swlist -i
To view the readme file for a product :
# swlist -a readme OS-Core
To find out Which Operating Environment Currently installed
# swlist -l bundle | grep HPUX11i
To generate a comprehensive listing that includes all filesets for the product NETWORKING
# swlist -v -l fileset NETWORKING
To find out which product a file belongs to 1st way, its slow:
# swlist -l file |grep /bin/ls
2nd way much quicker, as root:
# find /var/adm/sw/products -name INFO -exec grep -l /bin/ls {} +
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment